Venalis 12:Das Update verzögert sich durch kurzfristige Änderungen bei E-Rechnung, TSE 2.0 und Anwendungsschutz.Aktuellen Stand lesen →
Venalis Wiki · Handbuchstand August 2020

5. Hauptmenü

Aus dem Venalis Anwenderhandbuch übernommen. Inhaltlich noch Stand August 2020; Aktualisierungen für Venalis 12 folgen schrittweise.

5. Hauptmenü

Das Hauptmenü oder auch Cockpit genannt ist die Schaltzentrale von Venalis. Von hier aus gelangen Sie in alle Programmbereiche die Ihnen zur Verfügung stehen. Darüber hinaus versorgt Sie Venalis hier mit vielen Informationen die in frei positionierbaren Fenstern angezeigt werden. Welche Fenster und Informationen angezeigt werden hängt davon ab, welche Sie unter Ansicht aktiviert haben und welche davon für Sie vom Administrator freigeschaltet wurden. Dies kann entweder Anwenderabhängig erfolgen oder global in den Programmeinstellungen für alle Anwender. Venalis ist eine MDI-Anwendung (Multiple Document Interface). Das bedeutet, dass Listenfenster wie z.B. die Stammdaten Artikel, Kunden. Lieferanten, aber auch Vorgänge mehrfach geöffnet werden können. Dabei spielt es keine Rolle ob Sie das gleiche oder andere Fenster öffnen. Wird mehr als ein Fenster geöffnet, werden diese in der Taskbar angezeigt und können durch Klick auf den Fensternamen ausgewählt werden.

Unter dem Menüpunkt "Fenster" können Sie wählen, ob die Fenster übereinander, nebeneinander (vertikal oder horizontal) oder überlappend dargestellt werden sollen. Mit der Option "Fenster immer im Vollbild öffnen" stehen diese Optionen nicht zur Verfügung. Die Fenster werden dann grundsätzlich in voller Größe (eingebettet in das Hauptfenster) angezeigt und können nur über die Taskbar ausgewählt werden. Die Taskbar finden Sie unterhalb der Button-Toolbar. Sobald ein Listenfenster geöffnet wird, wird die Hauptmenüleiste leicht ausgegraut angezeigt. Das bedeutet nicht, dass diese nicht mehr aktiv ist, sondern dient zur besseren Übersicht.

Schnellstartleiste

Die Schnellstartleiste ist eine zusätzliche Möglichkeit neben dem Hauptmenü oder der Buttons in der Toolbar Programmfunktionen auszuwählen. Wie alle Fenster auf der Hauptseite lässt sich auch die Schnellstartleiste verschieben. Angezeigt werden nur die Menüpunkte die für Sie freigeschaltet wurden oder aufgrund der Venalis Version zur Verfügung stehen.

Systeminfo

Das Systeminfofenster zeigt beim Programmstart zunächst die aktuelle Venalis Version als Logo an, ändert die Anzeige aber nach wenigen Sekunden in einige Informationen zu Vorgängen, Mails und Geburtstagen. Die hier dargestellten Informationen werden als HTML-Datei eingelesen und können beliebig angepasst werden. Die HTML-Datei liegt im Venalis Verzeichnis und trägt den Namen "v7news_blank.htm".

Neue E-Mails

Haben Sie Mailkonten angelegt und nutzen Sie den internen Mailclient (auch für den Abruf) wird alle x Minuten (siehe Maileinestellungen) geprüft, ob sich neue Nachrichten auf Ihrem Server befinden. Die Nachrichtenköpfe (Absender, Empfänger, Datum und Uhrzeit sowie der Betreff) werden dabei von Venalis hier angezeigt.

Umsatzstatistik / Umsatzzahlen

Diese beiden Fenster arbeiten zusammen. Die Umsatzstatistik zeigt je nach Auswahl (Buttons im Kopf des Fensters) den Umsatz pro Monat für das aktuelle Jahr und das Vorjahr, die Offenen Posten für Forderungen und Verbindlichkeiten, die Top Kunde, Top Lieferanten und Top Artikel nach Umsatz, sowie den Kassenumsatz nach Filialen getrennt. Gleichzeitig ändert sich für jede dieser Statistiken die Anzeige der Umsatzzahlen. Diese werden tabellarisch dargestellt.

Aufgaben / Wiedervorlagen und Kalender

Auch diese beiden Fenster sind miteinander verknüpft. Der Kalender zeigt nicht nur das aktuelle Datum an, sondern wirkt sich auf die Erstellung eines neuen Eintrags in den Aufgaben / Wiedervorlagen aus. Wählen Sie mit der Maus ein Datum, wird ein neuer Eintrag auf diesen Tag gelegt. Außerdem ändert sich die Ansicht der Tages, Wochen, Monats oder Jahresansicht. In der Aufgabenliste werden alle Einträge chronologisch von oben nach unten dargestellt, wobei der erste Eintrag des aktuellen Tages fokussiert wird. Mit Rechtsklick auf das Aufgabenoder Kalenderfensters erhalten Sie ein Kontextmenü für die verschiedenen Möglichkeiten der Aufgabenplanung.

Anrufprotokoll

Das Anrufprotokoll zeigt bei aktivierter TAPI oder NCID Schnittstelle eingehende Anrufer. Wird die Rufnummer erkannt, wird der Kunde oder Lieferant hier ebenfalls angezeigt. Auch hier steht Ihnen mit Rechtsklick ein Kontextmenü zur Verfügung.

Geburtstage

Das Geburtstagsfenster zeigt alle Geburtstage der Kunden, Lieferanten und Mitarbeiter innerhalb des voreingestellten Zeitraums in Tagen.

Angemeldete Benutzer

Bei aktiver Anwenderverwaltung und Einsatz von Venalis im Netzwerk werden Ihnen hier die in Venalis eingeloggten Anwender angezeigt.

Offene Tickets (Zusatzmodul)

Zeigt Ihnen eine Liste der zur Zeit noch offenen Tickets.

Schnellauskunft

Die Schnellauskunft ist so etwas wie ein Notizblock für Mitarbeiter. Hier können Sie neue Einträge mit Betreff und Nachricht hinterlegen die jeder Mitarbeiter einsehen kann.

Vorgangsstatistik

Die Vorgangsstatistik zeigt die letzten 20 Rechnungen. Über die Programmeinstellungen kann diese Anwenderabhängig und alle letzten 20 Vorgänge gleich welcher Art anzeigen. Mit dem Menüpunkt Ansicht -> Fenster für Positionierung freigeben oder Ansicht -> Manuelles verschieben lassen sich sämtliche Fenster in der Größe anpassen oder auf dem Bildschirm positionieren. Der Menüpunkt Ansicht -> Aktuelle Positionierung speichern speichert die aktuelle Ausgangslage der Fenster.

Datei

Hier finden Sie Funktionen für die Serververwaltung, die Mandanten und den Menüpunkt zur Datensicherung.

5.1. Serververwaltung

In den Servereinstellungen hinterlegen Sie Ihre SQL-Server für die Venalis Datenbank(en). Wenn Sie z.B. von unserem mitgelieferten Microsoft SQL- Server auf eine neuere Version oder einen andern SQL-Server z.B. MariaDB oder MySQL umstellen wollen, können Sie hier weitere Server einrichten. Wir empfehlen, obwohl wir Microsoft SQL Server mitliefern, MariaDB. Mit dem Button "Neu", dem Menüpunkt Bearbeiten ->Neu oder die Taste <EINFÜGEN> legen Sie eine neue Serververbindung an. Durch Doppelklick, der Taste <ENTER> bearbeiten Sie eine bestehende Serververbindung. Löschen können Sie eine Serververbindung durch den Button "Löschen" oder der Taste <ENTFERNEN>. Wenn Sie einen bestehenden Server bearbeiten oder einen neuen Server erstellen, öffnet sich ein Dialog indem Sie folgende Eingaben hinterlegen müssen.

Serverbezeichnung

Die Serverbezeichnung ist ein für Sie identifizierbarer Name. Geben Sie hier etwas eindeutiges ein, damit Sie die Server unterscheiden können.

Servername

Hinterlegen Sie die IP-Adresse (z.B. 192.168.1.99) oder den Hostnamen und bei Einsatz von MS-SQL-Server die Instanz (z.B. SQLExpress oder VENALIS).

Servertyp

Wählen Sie um welchen Server es sich handelt. Entweder Microsoft SQL- Server oder MySQL. Bei Einsatz von MariaDB wählen Sie ebenfalls MySQL!

Username / Passwort

Der Username und das Passwort für den Zugriff auf den SQL-Server. Dies muss bei Microsoft SQL Server "sa" und bei MySQL / MariaDB "root" sein, da Venalis Administrator-Rechte benötigt.

Port

Muss nur bei MySQL angegeben werden und ist dann in der Regel 3306

Authentication

Nur bei Microsoft SQL Server, entweder Benutzername (Standard) oder Windows.

Cloud-Server

Setzen Sie hier nur einen Haken wenn es sich bei dem Server a) um einen Web-Server handelt und b) ein Eintrag unter Datenbank hinterlegt ist.

Datenbank

Nur wenn es sich um einen Web-Server handelt. Geben Sie in diesem Fall den Namen der Datenbank ein, die Sie auf Ihrem MySQL oder MariaDB Server im Web angelegt haben. Mit dem Schalter Cloud-Server und der hinterlegten Datenbank haben Sie die Möglichkeit, Venalis als Cloud-Lösung / Filiallösung an verschiedenen Orten zu betreiben. Klicken Sie auf den Button "Verbindung testen". Wird die LED anschließend grün, ist die Verbindung hergestellt. Bestätigen Sie die Auswahl mit OK und in der Serverliste anschließend mit dem Toolbutton "Auswahl". Venalis legt jetzt die Datenbankstruktur an.

5.2. Datenbankauswahl (Mandanten)

In der Mandantenverwaltung sind die verfügbaren Mandanten (Datenbanken) hinterlegt. Durch Doppelklick auf einen Mandanten in der Liste wird dieser ausgewählt. Handelt es sich um einen Mandanten den Sie längere Zeit nicht geöffnet haben, kann es sein, dass nach Auswahl eine Datenbanküberprüfung durchgeführt wird. Mit dem Button "Neu", dem Menüpunkt Bearbeiten ->Neu oder die Taste <EINFÜGEN> legen Sie einen neuen Mandanten an. Durch Doppelklick, der Taste <ENTER> bearbeiten Sie einen bestehenden Mandanten. Löschen können Sie einen Mandanten durch den Button "Löschen" oder der Taste <ENTFERNEN> und durch den Button <KOPIEREN> wird der ausgewählte Mandant dupliziert. Zusätzlich zur Anlage von Mandanten können Sie hier eine Datensicherung des ausgewählten Mandanten durchführen. Venalis sichert zunächst die Datenbank am von Ihnen hinterlegten Speicherort (siehe hierzu Programmeinstellungen TAB Seite 2) und packt diese anschließend in ein Archiv damit diese komprimiert wird. Das Archiv ist ein "Windows Cabinet File" (*.cab) und kann durch Doppelklick geöffnet oder Rechtsklick -> Extrahieren ausgepackt werden.

Bei einer Rücksicherung ist folgendes zu beachten. Handelt es sich um einen MySQL oder MariaDB Server, dann können Sie den Mandanten in der Liste auswählen und anschließend auf "Mandanten zurück sichern" klicken. Wählen Sie im Dateidialog die entpackte *.bak Datei, sichert Venalis automatisch zurück. Handelt es sich um einem Microsoft SQL Server, müssen Sie 1. einen anderen als den zurück zu sichernden Mandanten aktivieren, mit dem Cursor dann auf den zurück zu sichernden positionieren und anschließend wie beschrieben verfahren. Dabei muss der gesicherte Mandant den gleichen Namen besitzen wie die Datenbank die hier angezeigt wird und es muss exakt die gleiche Serverversion sein. Beispiel Microsoft SQL Server: Sie haben einen Mandanten mit dem Namen tsf_00001 gesichert. Haben Sie bereits mehrere Mandanten, wählen Sie z.B. tsf_00002 aus oder legen Sie einen weiteren an um diesen wählen zu können. Ist der Mandant aktiv, positionieren Sie den Cursor auf die Datenbank tsf_00001 und sichern Sie zurück.

5.3. Datensicherung

Mit dem Button "Datensicherung" wird eine Sicherung des aktiven Mandanten durchgeführt. Voraussetzung ist ein hinterlegter Sicherungspfad. Siehe hierzu Vorgaben -> Programmeinstellungen -> Vorgaben 2 s. Seite 118 Vorgaben 2